• 设为首页
  • 点击收藏
  • 手机版
    手机扫一扫访问
    迪恩网络手机版
  • 关注官方公众号
    微信扫一扫关注
    迪恩网络公众号

2015南阳CCPCG-AncientGo暴力

原作者: [db:作者] 来自: [db:来源] 收藏 邀请

G - Ancient Go

Time Limit: 1 Sec  

Memory Limit: 256 MB

题目连接

Description



Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

    The game is played on a 8×8 cell board, the chess can be put on the intersection of the board lines, so there are 9×9 different positions to put the chess.
    Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
    The chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board.
    When one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components.

One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's chess.



Input

The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. . represents an empty cell. x represents a cell with black chess which owned by Yu Zhou. o represents a cell with white chess which owned by Su Lu.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou has a move to kill at least one of Su Lu's components. Can not kill in one move!!! otherwise.

Sample Input

2

.......xo
.........
.........
..x......
.xox....x
.o.o...xo
..o......
.....xxxo
....xooo.

......ox.
.......o.
...o.....
..o.o....
...o.....
.........
.......o.
...x.....
........o

Sample Output

Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!

HINT

 

题意

下围棋,让你下一粒子,然后问你能否至少围住一个o

题解:

数据范围才9*9,直接瞎暴力就行了

枚举每一个位置,都下一个子,然后check就好了

代码:

#include<stdio.h>
#include<iostream>
#include<math.h>
#include<cstring>
using namespace std;

string s[10];
int vis[10][10];
int dx[4]={1,-1,0,0};
int dy[4]={0,0,1,-1};
int check2(int x,int y)
{
    vis[x][y]=1;
    if(x<0||x>=9||y<0||y>=9)return 0;
    for(int i=0;i<4;i++)
    {
        int xx = x+dx[i];
        int yy = y+dy[i];
        if(xx<0||xx>=9||yy<0||yy>=9)continue;
        if(vis[xx][yy])continue;
        if(s[xx][yy]=='.')return 1;
        if(s[xx][yy]=='o'&&check2(xx,yy))
            return 1;
    }
    return 0;
}
int check(int x,int y)
{
    if(s[x][y]!='.')return 0;
    s[x][y]='x';
    for(int i=0;i<4;i++)
    {
        int xx = x+dx[i];
        int yy = y+dy[i];
        if(xx<0||xx>=9||yy<0||yy>=9)continue;
        if(s[xx][yy]=='o')
        {
            memset(vis,0,sizeof(vis));
            if(!check2(xx,yy))
                return 1;
        }
    }
    s[x][y]='.';
    return 0;
}
int main()
{
    int t;scanf("%d",&t);
    for(int cas=1;cas<=t;cas++)
    {
        for(int i=0;i<9;i++)
            cin>>s[i];
        int flag = 0;
        for(int i=0;i<9;i++)
        {
            for(int j=0;j<9;j++)
            {
                if(s[i][j]=='o'||s[i][j]=='x')continue;
                if(check(i,j))
                {
                    flag = 1;
                    s[i][j]='.';
                    break;
                }
            }
        }
        if(flag)
            printf("Case #%d: Can kill in one move!!!\n",cas);
        else
            printf("Case #%d: Can not kill in one move!!!\n",cas);
    }
}

 


鲜花

握手

雷人

路过

鸡蛋
该文章已有0人参与评论

请发表评论

全部评论

专题导读
上一篇:
第一个GO程序发布时间:2022-07-10
下一篇:
Filecoin周报-41:存储市场大变动,go-filecoin正式接入lotus!发布时间:2022-07-10
热门推荐
热门话题
阅读排行榜

扫描微信二维码

查看手机版网站

随时了解更新最新资讯

139-2527-9053

在线客服(服务时间 9:00~18:00)

在线QQ客服
地址:深圳市南山区西丽大学城创智工业园
电邮:jeky_zhao#qq.com
移动电话:139-2527-9053

Powered by 互联科技 X3.4© 2001-2213 极客世界.|Sitemap